GLog & GFlags 的安装

0、系统环境
Ubuntu 16.04
GCC 5.4

1、安装步骤
1)安装 GFlags
运行如下指令:

2)安装 GLog:
安装编译工具:

运行如下指令安装:

常见问题
1、使用 GLog 报错:libglog.a: error adding symbols: Bad value
在使用 GLog 的工程中遇到了如下错误:

产生该问题的可能原因是在 64位系统中,不能链接 GLog 生成动态库。修改方法是 GLog 需要使用如下方式编译,加入 -fPIC 编译选项:

代替:

2、错误:undefined reference to `google::FlagRegisterer::FlagRegisterer
如果你在编译 GLog 时遇到如下错误:

可以尝试先卸载 GFlags:

然后重新编译
另一种可能的解决方案是,在编译 GLog 时请使用:

代替:

3、错误:Make error: failed to link with libgflags.a
产生该问题的原因有可能是需要使用动态库方式编译 GFlags
将 GFlags 编译时选项改成动态库:

并重新编译 GFlags 和 GLog。

4、错误:something wrong with flag ‘flagfile’ in file ‘XXX.cc’
请参照 3 中的解决方案重新编译 GFlags 和 GLog。

About skylook

增强现实、图像识别技术爱好者。
This entry was posted in 其他工具. Bookmark the permalink.

发表评论

电子邮件地址不会被公开。




Optimization WordPress Plugins & Solutions by W3 EDGE